Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13eGN3LXJxeGMtaGo4Nc2owA

FTP backend for Duplicity Discloses Passwords to Process Listing

The FTP backend for Duplicity before 0.4.9 sends the password as a command line argument when calling ncftp, which might allow local users to read the password by listing the process and its arguments.

Permalink: https://github.com/advisories/GHSA-wxcw-rqxc-hj85
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS13eGN3LXJxeGMtaGo4Nc2owA
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 8 months ago


Identifiers: GHSA-wxcw-rqxc-hj85, CVE-2007-5201
References: Blast Radius: 0.0

Affected Packages

pypi:duplicity
Dependent packages: 1
Dependent repositories: 2,062
Downloads: 5,602 last month
Affected Version Ranges: < 0.4.9
Fixed in: 0.4.9
All affected versions:
All unaffected versions: 0.8.13, 0.8.14, 0.8.15, 0.8.16, 0.8.17, 0.8.18, 0.8.19, 0.8.20, 0.8.21, 0.8.22, 0.8.23, 1.0.0, 1.0.1, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 2.0.0, 2.0.2, 2.1.0, 2.1.1, 2.1.3, 2.1.4, 2.1.5, 2.2.1, 2.2.2, 2.2.3