Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14MjRtLXdyMmYtcDN2Y84AAivb

Jenkins Google Compute Engine Plugin Cross-Site Request Forgery vulnerability

A cross-site request forgery vulnerability in Jenkins Google Compute Engine Plugin 4.1.1 and earlier in ComputeEngineCloud#doProvision could be used to provision new agents. Google Compute Engine Plugin 4.2.0 requires POST requests for this API endpoint.

Permalink: https://github.com/advisories/GHSA-x24m-wr2f-p3vc
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14MjRtLXdyMmYtcDN2Y84AAivb
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 7 months ago


CVSS Score: 4.3
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Identifiers: GHSA-x24m-wr2f-p3vc, CVE-2019-16548
References: Repository: https://github.com/jenkinsci/google-compute-engine-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:google-compute-engine
Affected Version Ranges: <= 4.1.1
Fixed in: 4.2.0