Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14NW03LXJ3Zngtdzdxbc4AArmG

Remote Code Execution in Apache Flume

Apache Flume versions 1.4.0 through 1.9.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Permalink: https://github.com/advisories/GHSA-x5m7-rwfx-w7qm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14NW03LXJ3Zngtdzdxbc4AArmG
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: 9 months ago


Identifiers: GHSA-x5m7-rwfx-w7qm, CVE-2022-25167
References: Repository: https://github.com/apache/flume
Blast Radius: 0.0

Affected Packages

maven:org.apache.flume.flume-ng-sources:flume-jms-source
Dependent packages: 3
Dependent repositories: 124
Downloads:
Affected Version Ranges: >= 1.4.0, < 1.10.0
Fixed in: 1.10.0
All affected versions: 1.4.0, 1.5.0, 1.5.1, 1.5.2, 1.6.0, 1.7.0, 1.8.0, 1.9.0
All unaffected versions: 1.10.0, 1.10.1, 1.11.0