Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14OXJxLTloNDQtZjg0ds4AAk1J

Stored XSS vulnerability in Jenkins ECharts API Plugin

ECharts API Plugin 4.7.0-3 and earlier does not escape the parser identifier when rendering charts.

This results in a stored cross-site scripting (XSS) vulnerability that can be exploited by users with Job/Configure permission.

ECharts API Plugin 4.7.0-4 escapes the parser identifier.

Permalink: https://github.com/advisories/GHSA-x9rq-9h44-f84v
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14OXJxLTloNDQtZjg0ds4AAk1J
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-x9rq-9h44-f84v, CVE-2020-2193
References: Blast Radius: 1.0

Affected Packages

maven:io.jenkins.plugins:echarts-api
Affected Version Ranges: < 4.7.0-4
Fixed in: 4.7.0-4