Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14ZmhwLWpmOHAtbWg1d84AA9WW

HashiCorp go-getter Vulnerable to Code Execution On Git Update Via Git Config Manipulation

HashiCorp’s go-getter library can be coerced into executing Git update on an existing maliciously modified Git Configuration, potentially leading to arbitrary code execution. When go-getter is performing a Git operation, go-getter will try to clone the given repository in a specified destination. Cloning initializes a git config to the provided destination and if the repository needs to get updated go-getter will pull the new changes .

An attacker may alter the Git config after the cloning step to set an arbitrary Git configuration to achieve code execution.

Permalink: https://github.com/advisories/GHSA-xfhp-jf8p-mh5w
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14ZmhwLWpmOHAtbWg1d84AA9WW
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 19 days ago
Updated: 16 days ago


CVSS Score: 8.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H

Identifiers: GHSA-xfhp-jf8p-mh5w, CVE-2024-6257
References: Repository: https://github.com/hashicorp/go-getter
Blast Radius: 32.6

Affected Packages

go:github.com/hashicorp/go-getter
Dependent packages: 3,705
Dependent repositories: 6,872
Downloads:
Affected Version Ranges: < 1.7.5
Fixed in: 1.7.5
All affected versions: 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.1.0, 1.2.0, 1.3.0, 1.4.0, 1.4.1, 1.4.2, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.5.9, 1.5.10, 1.5.11, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.7.2, 1.7.3
All unaffected versions: