Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14ZngzLWNyNzQteDNjds4AA9Xv

Exposure of secrets through system log in Jenkins Structs Plugin

Structs Plugin provides utility functionality used, e.g., in Pipeline to instantiate and configure build steps, typically before their execution.

When Structs Plugin 337.v1b_04ea_4df7c8 and earlier fails to configure a build step, it logs a warning message containing diagnostic information that may contain secrets passed as step parameters.

This can result in accidental exposure of secrets through the default system log.

Structs Plugin 338.v848422169819 inspects the types of actual parameters before logging these warning messages, and limits detailed diagnostic information to FINE level log messages if secrets are involved. These log messages are not displayed in the default Jenkins system log.

Permalink: https://github.com/advisories/GHSA-xfx3-cr74-x3cv
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14ZngzLWNyNzQteDNjds4AA9Xv
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: 21 days ago
Updated: 21 days ago


CVSS Score: 3.1
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N

Identifiers: GHSA-xfx3-cr74-x3cv, CVE-2024-39458
References: Repository: https://github.com/jenkinsci/structs-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:structs
Affected Version Ranges: < 338.v848422169819
Fixed in: 338.v848422169819