Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14ZzV2LTY5NmgtYzN2cs4AAXVN

Cloud Foundry UAA SessionID present in Audit Event Logs

In Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3, the SessionID is logged in audit event logs. An attacker can use the SessionID to impersonate a logged-in user.

Permalink: https://github.com/advisories/GHSA-xg5v-696h-c3vr
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14ZzV2LTY5NmgtYzN2cs4AAXVN
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: about 2 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-xg5v-696h-c3vr, CVE-2018-1192
References: Repository: https://github.com/cloudfoundry/uaa
Blast Radius: 10.3

Affected Packages

maven:org.cloudfoundry.identity:cloudfoundry-identity-server
Dependent packages: 3
Dependent repositories: 15
Downloads:
Affected Version Ranges: >= 4.8.0, < 4.8.3, >= 4.6.0, < 4.7.4, < 4.5.5
Fixed in: 4.8.3, 4.7.4, 4.5.5
All affected versions: 3.0.0, 3.0.1, 3.1.0, 3.2.0, 3.2.1, 3.3.0, 3.4.0, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.5.0, 3.6.0, 3.7.0, 3.7.3, 3.8.0, 3.9.0, 3.9.1, 3.10.0, 3.12.0, 3.13.0, 3.15.0, 3.16.0, 3.18.0, 3.19.0, 3.20.0, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.5.0, 4.6.0, 4.6.1, 4.7.0, 4.7.1, 4.7.2, 4.8.0, 4.8.2
All unaffected versions: 4.5.6, 4.5.7, 4.5.8, 4.5.9, 4.7.4, 4.7.5, 4.7.6, 4.8.3, 4.9.0, 4.10.0, 4.10.1, 4.10.2, 4.11.0, 4.12.0, 4.12.1, 4.12.2, 4.12.3, 4.12.4, 4.13.0, 4.13.1, 4.13.3, 4.13.4, 4.14.0, 4.15.0, 4.16.0, 4.17.0, 4.18.0, 4.19.0, 4.19.2, 4.20.0, 4.21.0, 4.22.0, 4.23.0, 4.24.0, 4.25.0, 4.26.0, 4.27.0, 4.30.0