Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14aDRtLTk5cXAtdzQ4M84AAWcL

Cloud Foundry UAA open redirect

Cloud Foundry UAA, versions later than 4.6.0 and prior to 4.19.0 except 4.10.1 and 4.7.5 and uaa-release versions later than v48 and prior to v60 except v55.1 and v52.9, does not validate redirect URL values on a form parameter used for internal UAA redirects on the login page, allowing open redirects. A remote attacker can craft a malicious link that, when clicked, will redirect users to arbitrary websites after a successful login attempt.

Permalink: https://github.com/advisories/GHSA-xh4m-99qp-w483
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14aDRtLTk5cXAtdzQ4M84AAWcL
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: about 2 months ago


CVSS Score: 6.1
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-xh4m-99qp-w483, CVE-2018-11041
References: Repository: https://github.com/cloudfoundry/uaa
Blast Radius: 7.2

Affected Packages

maven:org.cloudfoundry.identity:cloudfoundry-identity-server
Dependent packages: 3
Dependent repositories: 15
Downloads:
Affected Version Ranges: >= 4.13.0, < 4.19.0, >= 4.11.0, < 4.12.3, >= 4.8.0, < 4.10.1, < 4.7.5
Fixed in: 4.19.0, 4.12.3, 4.10.1, 4.7.5
All affected versions: 3.0.0, 3.0.1, 3.1.0, 3.2.0, 3.2.1, 3.3.0, 3.4.0, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.5.0, 3.6.0, 3.7.0, 3.7.3, 3.8.0, 3.9.0, 3.9.1, 3.10.0, 3.12.0, 3.13.0, 3.15.0, 3.16.0, 3.18.0, 3.19.0, 3.20.0, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.5.0, 4.5.6, 4.5.7, 4.5.8, 4.5.9, 4.6.0, 4.6.1, 4.7.0, 4.7.1, 4.7.2, 4.7.4, 4.8.0, 4.8.2, 4.8.3, 4.9.0, 4.10.0, 4.11.0, 4.12.0, 4.12.1, 4.12.2, 4.13.0, 4.13.1, 4.13.3, 4.13.4, 4.14.0, 4.15.0, 4.16.0, 4.17.0, 4.18.0
All unaffected versions: 4.7.5, 4.7.6, 4.10.1, 4.10.2, 4.12.3, 4.12.4, 4.19.0, 4.19.2, 4.20.0, 4.21.0, 4.22.0, 4.23.0, 4.24.0, 4.25.0, 4.26.0, 4.27.0, 4.30.0