Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14ajI5LWdmd3ctajY3Z84AAygB

Jenkins JaCoCo Plugin vulnerable to Stored Cross-site Scripting

Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control input files for the 'Record JaCoCo coverage report' post-build action. Version 3.3.2.1 escapes class and method names shown on the UI.

Permalink: https://github.com/advisories/GHSA-xj29-gfww-j67g
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14ajI5LWdmd3ctajY3Z84AAygB
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: 6 months ago


CVSS Score: 8.0
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-xj29-gfww-j67g, CVE-2023-28669
References: Repository: https://github.com/jenkinsci/jacoco-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:jacoco
Affected Version Ranges: < 3.3.2.1
Fixed in: 3.3.2.1