Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14cXF3LWNxanAtNTJ4bc4AAiIG

Jenkins Log Parser Plugin vulnerable to Cross-site Scripting

Log Parser Plugin did not escape an error message shown when log parsing patterns are invalid. This resulted in a persisted cross-site scripting vulnerability exploitable by attackers able to control the log parsing rules configuration, typically users with Job/Configure permission.

Jenkins applies the missing escaping by default since 2.146 and LTS 2.138.2, so newer Jenkins releases are not affected by this vulnerability.

Log Parser Plugin version 2.1 escapes all variables displayed in its views.

Permalink: https://github.com/advisories/GHSA-xqqw-cqjp-52xm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14cXF3LWNxanAtNTJ4bc4AAiIG
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-xqqw-cqjp-52xm, CVE-2019-10410
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:log-parser
Affected Version Ranges: < 2.1
Fixed in: 2.1