Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14cjM3LXBqZmgtcXd3Y84AAjcY

Fortify Plugin stored credentials in plain text

Fortify Plugin 19.1.29 and earlier stored its proxy server password unencrypted in job config.xml files. This password could be read by users with the Extended Read permission.

Fortify Plugin 19.2.30 now encrypts the proxy server password.

Permalink: https://github.com/advisories/GHSA-xr37-pjfh-qwwc
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14cjM3LXBqZmgtcXd3Y84AAjcY
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 4.3
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-xr37-pjfh-qwwc, CVE-2020-2107
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:fortify
Affected Version Ranges: <= 19.1.29
Fixed in: 19.2.30