Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS14cmgyLWMzcm0tMzVqcs4AAq-v

HornetQ REST vulnerable to Improper Restriction of XML External Entity Reference

HornetQ REST is vulnerable to XML External Entity due to insecure configuration of RestEasy.

Permalink: https://github.com/advisories/GHSA-xrh2-c3rm-35jr
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS14cmgyLWMzcm0tMzVqcs4AAq-v
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 6.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Identifiers: GHSA-xrh2-c3rm-35jr, CVE-2014-3599
References: Repository: https://github.com/hornetq/hornetq
Blast Radius: 8.2

Affected Packages

maven:org.hornetq.rest:hornetq-rest
Dependent packages: 0
Dependent repositories: 18
Downloads:
Affected Version Ranges: < 2.5.0.Beta1
Fixed in: 2.5.0.Beta1
All affected versions:
All unaffected versions: