Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1jMzcyLXg1N3AtNng3ds2_bw

Apache Geronimo Application Server multiple cross-site scripting (XSS) vulnerabilities

Multiple cross-site scripting (XSS) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to inject arbitrary web script or HTML via the (1) name, (2) ip, (3) username, or (4) description parameter to console/portal/Server/Monitoring; or (5) the PATH_INFO to the default URI under console/portal/.

Permalink: https://github.com/advisories/GHSA-c372-x57p-6x7v
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1jMzcyLXg1N3AtNng3ds2_bw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: about 2 months ago


Identifiers: GHSA-c372-x57p-6x7v, CVE-2009-0038
References: Repository: https://github.com/apache/geronimo
Blast Radius: 1.0

Affected Packages

maven:org.apache.geronimo.plugins:console
Dependent packages: 0
Dependent repositories: 0
Downloads:
Affected Version Ranges: >= 2.1.0, < 2.1.4
Fixed in: 2.1.4
All affected versions: 2.1.1, 2.1.2, 2.1.3
All unaffected versions: 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.2.1, 3.0.0, 3.0.1