Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1jNTd2LTR2ZzUtY20yeM4AA5I5

Apache Pulsar SASL Authentication Provider observable timing discrepancy vulnerability

Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification.
Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the saslJaasServerRoleTokenSignerSecretPath file.

Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker.

2.11 Pulsar users should upgrade to at least 2.11.3.
3.0 Pulsar users should upgrade to at least 3.0.2.
3.1 Pulsar users should upgrade to at least 3.1.1.
Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions.

For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .

Permalink: https://github.com/advisories/GHSA-c57v-4vg5-cm2x
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1jNTd2LTR2ZzUtY20yeM4AA5I5
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 23 days ago
Updated: 15 days ago


CVSS Score: 7.4
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Identifiers: GHSA-c57v-4vg5-cm2x, CVE-2023-51437
References:

Affected Packages

maven:org.apache.pulsar:pulsar-broker-auth-sasl
Versions: >= 3.1.0, < 3.1.1, >= 3.0.0, < 3.0.2, < 2.11.3
Fixed in: 3.1.1, 3.0.2, 2.11.3