Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1jNThqLTg4ZjUtaDUzZs4AAtG3

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in pycares

Impact

pycares versions < 4.2.0 are affected by CVE-2021-3672.

Patches

Update to version 4.2.0.

Permalink: https://github.com/advisories/GHSA-c58j-88f5-h53f
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1jNThqLTg4ZjUtaDUzZs4AAtG3
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 5.6
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Identifiers: GHSA-c58j-88f5-h53f
References: Repository: https://github.com/saghul/pycares
Blast Radius: 19.1

Affected Packages

pypi:pycares
Dependent packages: 21
Dependent repositories: 2,612
Downloads: 3,227,089 last month
Affected Version Ranges: < 4.2.0
Fixed in: 4.2.0
All affected versions: 0.1.0, 0.2.0, 0.3.0, 0.4.0, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.7.0, 1.0.0, 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.3.0, 2.4.0, 3.0.0, 3.1.0, 3.1.1, 3.2.0, 3.2.3, 4.0.0, 4.1.1, 4.1.2
All unaffected versions: 4.2.0, 4.2.1, 4.2.2, 4.3.0, 4.4.0