Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1jNnBoLW04Y3ctcmZxaM4AA4K2

PaddlePaddle floating point exception in paddle.linalg.eig

FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.

Permalink: https://github.com/advisories/GHSA-c6ph-m8cw-rfqh
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1jNnBoLW04Y3ctcmZxaM4AA4K2
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 4 months ago
Updated: 4 months ago


CVSS Score: 4.7
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L

Identifiers: GHSA-c6ph-m8cw-rfqh, CVE-2023-38677
References: Repository: https://github.com/PaddlePaddle/Paddle
Blast Radius: 15.7

Affected Packages

pypi:paddlepaddle
Dependent packages: 41
Dependent repositories: 2,208
Downloads: 197,528 last month
Affected Version Ranges: < 2.6.0
Fixed in: 2.6.0
All affected versions: 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.7.0, 1.7.1, 1.7.2, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 2.0.0, 2.0.1, 2.0.2, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.3.2, 2.4.0, 2.4.1, 2.4.2, 2.5.0, 2.5.1, 2.5.2
All unaffected versions: 2.6.0, 2.6.1