Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1jZjJqLXZmMzYtYzZ3OM0WxA

Communities and collections administrators can escalate their privilege up to system administrator

Impact

Any community or collection administrator can escalate their permission up to become system administrator.

This vulnerability only existed in 7.0 and does not impact 6.x or below.

Patches

Fix is included in 7.1. Please upgrade to 7.1 at your earliest convenience.

Workarounds

In 7.0, temporarily disable the ability for community or collection administrators to manage permissions or workflows settings, i.e. set the following properties in your local.cfg / dspace.cfg file

core.authorization.collection-admin.policies = false
core.authorization.community-admin.policies = false
core.authorization.community-admin.collection.workflows = false

Once upgraded to 7.1, these settings can be safely reverted to the default values of true.

References

Discovered during investigation of https://github.com/DSpace/DSpace/issues/7928

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-cf2j-vf36-c6w8
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1jZjJqLXZmMzYtYzZ3OM0WxA
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: about 1 year ago


CVSS Score: 7.2
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-cf2j-vf36-c6w8, CVE-2021-41189
References: Repository: https://github.com/DSpace/DSpace
Blast Radius: 18.0

Affected Packages

maven:org.dspace:dspace-api
Dependent packages: 45
Dependent repositories: 319
Downloads:
Affected Version Ranges: >= 7.0, < 7.1
Fixed in: 7.1
All affected versions:
All unaffected versions: 1.5.0, 1.5.1, 1.5.2, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 7.1.1, 7.2.1, 7.6.1