Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1jaGozLWY3eHctMzY3bc4AArf7

OS Command Injection in git-promise

All versions of package git-promise is vulnerable to Command Injection due to an inappropriate fix of a prior vulnerability in this package. Note: Please note that the vulnerability will not be fixed. The README file was updated with a warning regarding this issue.

Credits

@lirantal for discovering this vulnerability.

Permalink: https://github.com/advisories/GHSA-chj3-f7xw-367m
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1jaGozLWY3eHctMzY3bc4AArf7
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 7.2
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-chj3-f7xw-367m, CVE-2022-24376
References: Repository: https://github.com/lirantal/git-promise
Blast Radius: 20.1

Affected Packages

npm:git-promise
Dependent packages: 54
Dependent repositories: 626
Downloads: 7,924 last month
Affected Version Ranges: <= 1.0.0
No known fixed version
All affected versions: 0.1.0, 0.2.0, 0.3.0, 0.3.1, 1.0.0