Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1jbTdmLWhmMmctZ2hycM4AAwCw

PyroCMS vulnerable to stored Cross Site Scripting

PyroCMS 3.9 is vulnerable to a stored Cross Site Scripting (XSS) when a low privileged user, such as an author, injects a crafted html and javascript payload in a blog post, leading to full admin account takeover or privilege escalation.

Permalink: https://github.com/advisories/GHSA-cm7f-hf2g-ghrp
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1jbTdmLWhmMmctZ2hycM4AAwCw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: 6 months ago
Updated: 4 months ago


CVSS Score: 9.0
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Identifiers: GHSA-cm7f-hf2g-ghrp, CVE-2022-37721
References:

Affected Packages

packagist:pyrocms/pyrocms
Versions: <= 3.9.1
No known fixed version