Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Advisories: GSA_kwCzR0hTQS1jcTRwLXZwNXEtNDUyMs4AAxI-

Plaintext storage of sensitive data in Rancher API and cluster.management.cattle.io objects

Impact

This issue affects Rancher versions from 2.5.0 up to and including 2.5.16, from 2.6.0 up to and including 2.6.9 and 2.7.0. It was discovered that the security advisory CVE-2021-36782 (GHSA-g7j7-h4q8-8w2f), previously released by Rancher, missed addressing some sensitive fields, secret tokens, encryption keys, and SSH keys that were still being stored in plaintext directly on Kubernetes objects like Clusters.

The exposed credentials are visible in Rancher to authenticated Cluster Owners, Cluster Members, Project Owners and Project Members of that cluster on the endpoints:

The remaining sensitive fields are now stripped from Clusters and other objects and moved to a Secret before the object is stored. The Secret is retrieved when the credential is needed. For objects that existed before this security fix, a one-time migration happens on startup.

The fields that have been addressed by this security fix are:

Important:

Workarounds

There is no direct mitigation besides updating Rancher to a patched version.

Patches

Patched versions include releases 2.5.17, 2.6.10, 2.7.1 and later versions.

After upgrading to a patched version, it is important to check for the ACISecretsMigrated and RKESecretsMigrated conditions on Clusters and ClusterTemplateRevisions to confirm when secrets have been fully migrated off of those objects, and the objects scoped within them.

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-cq4p-vp5q-4522

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: 4 days ago
Updated: 4 days ago

CVSS Score: 9.9
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Identifiers: GHSA-cq4p-vp5q-4522, CVE-2022-43757
References:

Affected Packages

go:github.com/rancher/rancher
Versions: >= 2.7.0, < 2.7.1, >= 2.6.0, < 2.6.10, >= 2.5.0, < 2.5.17
Fixed in: 2.7.1, 2.6.10, 2.5.17