Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1jdzJyLTRwODItcXY3Oc4AA4Dz

DoS with algorithms that use PBKDF2 due to unbounded PBES2 Count value

Impact

Denial of Service,
Applications that allow the use of the PBKDF2 algorithm.

Patches

A patch is available that sets the maximum number of default rounds.

Workarounds

Applications that do not need to use PBKDF2 should simply specify the algorithms use and exclude it from the list.
Applications that need to use the algorithm should upgrade to the new version that allows to set a maximum rounds number.

Acknowledgement

The issues was reported by Jingcheng Yang and Jianjun Chen from Sichuan University
and Zhongguancun Lab

Permalink: https://github.com/advisories/GHSA-cw2r-4p82-qv79
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1jdzJyLTRwODItcXY3Oc4AA4Dz
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 5 months ago
Updated: 4 days ago


CVSS Score: 5.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Identifiers: GHSA-cw2r-4p82-qv79, CVE-2023-6681
References: Repository: https://github.com/latchset/jwcrypto
Blast Radius: 17.5

Affected Packages

pypi:jwcrypto
Dependent packages: 86
Dependent repositories: 1,962
Downloads: 1,979,968 last month
Affected Version Ranges: < 1.5.1
Fixed in: 1.5.1
All affected versions: 0.2.0, 0.2.1, 0.3.0, 0.3.1, 0.4.0, 0.4.1, 0.4.2, 0.5.0, 0.6.0, 0.9.1, 1.3.1, 1.4.1, 1.4.2, 1.5.0
All unaffected versions: 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6