An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1mZzI1LWdxOWctMzJteM4AAu9Y

Cross site scripting in Cloudreve

Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago

CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-fg25-gq9g-32mx, CVE-2022-32167
References: Repository:
Blast Radius: 0.0

Affected Packages
Dependent packages: 0
Dependent repositories: 1
Affected Version Ranges: >= 3.0.0, < 3.6.0-beta1
Fixed in: 3.6.0-beta1
All affected versions:
All unaffected versions:
Dependent packages: 0
Dependent repositories: 0
Affected Version Ranges: >= 1.0.0, <= 2.0.0
No known fixed version
All affected versions: