Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1majY0LXFwcngtcTd2cc4AAz21

genson vulnerable to stack exhaustion

An issue was discovered genson through 1.6 allows attackers to cause a denial of service or other unspecified impacts via crafted objects that deeply nested structures.

Permalink: https://github.com/advisories/GHSA-fj64-qprx-q7vq
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1majY0LXFwcngtcTd2cc4AAz21
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 1 year ago
Updated: 8 months ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-fj64-qprx-q7vq, CVE-2023-34617
References: Repository: https://github.com/owlike/genson
Blast Radius: 22.1

Affected Packages

maven:com.owlike:genson
Dependent packages: 47
Dependent repositories: 876
Downloads:
Affected Version Ranges: <= 1.6
No known fixed version
All affected versions: