Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1mcTZoLTRnOHYtcXF2bc4AA5JK

CKEditor4 Cross-site Scripting vulnerability caused by incorrect CDATA detection

Affected packages

The vulnerability has been discovered in the core HTML parsing module and may affect all editor instances that:

Impact

A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional attack on the editor. It affects all users using the CKEditor 4 at version < 4.24.0-lts.

Patches

The problem has been recognized and patched. The fix will be available in version 4.24.0-lts.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank Michal Frýba from ALEF NULA for recognizing and reporting this vulnerability.

Permalink: https://github.com/advisories/GHSA-fq6h-4g8v-qqvm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1mcTZoLTRnOHYtcXF2bc4AA5JK
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 23 days ago
Updated: 10 days ago


CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-fq6h-4g8v-qqvm, CVE-2024-24815
References:

Affected Packages

packagist:ckeditor/ckeditor
Versions: < 4.24.0
Fixed in: 4.24.0
npm:ckeditor4
Versions: < 4.24.0-lts
Fixed in: 4.24.0-lts