Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1mcnFjLWYyaDgtZmp2Zs4AA19h

Spring for GraphQL may be exposed to GraphQL context with values from a different session

A batch loader function in Spring for GraphQL versions 1.1.0 - 1.1.5 and 1.2.0 - 1.2.2 may be exposed to GraphQL context with values, including security context values, from a different session. An application is vulnerable if it provides a DataLoaderOptions instance when registering batch loader functions through DefaultBatchLoaderRegistry.

Permalink: https://github.com/advisories/GHSA-frqc-f2h8-fjvf
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1mcnFjLWYyaDgtZmp2Zs4AA19h
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: 10 months ago
Updated: 8 months ago


CVSS Score: 3.1
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N

Identifiers: GHSA-frqc-f2h8-fjvf, CVE-2023-34047
References: Blast Radius: 6.9

Affected Packages

maven:org.springframework.graphql:spring-graphql
Dependent packages: 13
Dependent repositories: 174
Downloads:
Affected Version Ranges: >= 1.2.0, < 1.2.3, >= 1.1.0, < 1.1.6
Fixed in: 1.2.3, 1.1.6
All affected versions: 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.2.0, 1.2.1, 1.2.2
All unaffected versions: 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.1.6, 1.1.7, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.3.0