Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Advisories: GSA_kwCzR0hTQS1nM3B2LXBqNWYtM2hmcc4AAxCV

mechanize Regular Expression Denial of Service vulnerability

mechanize, a library for automatically interacting with HTTP web servers, contains a regular expression that is vulnerable to regular expression denial of service (ReDoS) prior to version 0.4.6. If a web server responds in a malicious way, then mechanize could crash. Version 0.4.6 has a patch for the issue.

Permalink: https://github.com/advisories/GHSA-g3pv-pj5f-3hfq

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 20 days ago
Updated: 17 days ago

CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-g3pv-pj5f-3hfq, CVE-2021-32837
References:

Affected Packages

pypi:mechanize
Versions: < 0.4.6
Fixed in: 0.4.6