Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1nN3c0LXI0bWctZ3ZoeM4AAkDR

XXE vulnerability in Jenkins RapidDeploy Plugin

RapidDeploy Plugin 4.2 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

This allows a user able to control the input files for the 'RapidDeploy deployment package build' build or post-build step to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller, server-side request forgery, or denial-of-service attacks.

RapidDeploy Plugin 4.2.1 disables external entity resolution for its XML parser.

Permalink: https://github.com/advisories/GHSA-g7w4-r4mg-gvhx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1nN3c0LXI0bWctZ3ZoeM4AAkDR
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago


CVSS Score: 7.6
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L

Identifiers: GHSA-g7w4-r4mg-gvhx, CVE-2020-2171
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:rapiddeploy-jenkins
Affected Version Ranges: < 4.2.1
Fixed in: 4.2.1