Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1nN3hxLXh2OGMtaDk4Y84AA7Da

Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags

Summary

There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data.

Our filter to detect and prevent the use of the javascript: URL scheme in the href attribute of an <a> tag could be bypassed with tab \t or newline \n characters between the characters of the protocol, e.g. java\tscript:.

Impact

If you render an <a> tag with an href attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user.

a(href: user_profile) { "Profile" }

Mitigation

The best way to mitigate this vulnerability is to update to one of the following versions:

Workarounds

Configuring a Content Security Policy that does not allow unsafe-inline would effectively prevent this vulnerability from being exploited.

Permalink: https://github.com/advisories/GHSA-g7xq-xv8c-h98c
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1nN3hxLXh2OGMtaDk4Y84AA7Da
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 1 month ago
Updated: about 1 month ago


CVSS Score: 7.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

Identifiers: GHSA-g7xq-xv8c-h98c, CVE-2024-32463
References: Repository: https://github.com/phlex-ruby/phlex
Blast Radius: 8.7

Affected Packages

rubygems:phlex
Dependent packages: 22
Dependent repositories: 17
Downloads: 205,435 total
Affected Version Ranges: < 1.4.2, >= 1.5.0, < 1.5.3, >= 1.6.0, < 1.6.3, >= 1.7.0, < 1.7.2, >= 1.8.0, < 1.8.3, >= 1.9.0, < 1.9.2, = 1.10.0
Fixed in: 1.4.2, 1.5.3, 1.6.3, 1.7.2, 1.8.3, 1.9.2, 1.10.1
All affected versions: 0.1.0, 0.2.0, 0.2.1, 0.2.2, 0.3.0, 0.3.1, 0.3.2, 0.4.0, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.2.2, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.4.0, 1.4.1, 1.5.0, 1.5.1, 1.5.2, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.8.0, 1.8.1, 1.8.2, 1.9.0, 1.9.1, 1.10.0
All unaffected versions: 1.4.2, 1.5.3, 1.6.3, 1.7.2, 1.8.3, 1.9.2, 1.9.3, 1.10.1, 1.10.2