Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1nNmhnLTR2M2MtNmpxN84AAvjS

Apache IoTDB subject to ReDOS with Java 8

Apache IoTDB versions 0.12.2 through 0.12.6, and 0.13.0 through 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. This issue is patched in 0.13.3. Users should upgrade or use a later version of Java to avoid it.

Permalink: https://github.com/advisories/GHSA-g6hg-4v3c-6jq7
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1nNmhnLTR2M2MtNmpxN84AAvjS
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 11 months ago
Updated: 8 months ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-g6hg-4v3c-6jq7, CVE-2022-43766
References:

Affected Packages

pypi:apache-iotdb
Versions: >= 0.13.0, < 0.14.0rc1
Fixed in: 0.14.0rc1
maven:org.apache.iotdb:iotdb-parent
Versions: >= 0.12.2, < 0.13.3
Fixed in: 0.13.3