An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1nY3Y5LTY3MzctcGpxd80mTg

SSRF vulnerability in jupyter-server-proxy


What kind of vulnerability is it? Server-Side Request Forgery ( SSRF )

Who is impacted? Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled.

A lack of input validation allowed authenticated clients to proxy requests to other hosts, bypassing the allowed_hosts check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity.


Has the problem been patched? What versions should users upgrade to?

Upgrade to 3.2.1, or apply the patch

For more information

If you have any questions or comments about this advisory:

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: about 1 year ago

CVSS Score: 6.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N

Identifiers: GHSA-gcv9-6737-pjqw, CVE-2022-21697
References: Repository:
Blast Radius: 16.8

Affected Packages

Dependent packages: 35
Dependent repositories: 456
Downloads: 192,937 last month
Affected Version Ranges: <= 3.2.0
Fixed in: 3.2.1
All affected versions: 1.0.1, 1.1.0, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.4.0, 1.5.0, 1.5.2, 1.5.3, 1.6.0, 3.0.0, 3.0.1, 3.0.2, 3.1.0, 3.2.0
All unaffected versions: 3.2.1, 3.2.2, 3.2.3, 4.0.0, 4.1.0, 4.1.1, 4.1.2