Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1nYzJyLWNjZmgtNjJ2Oc4AAoGF

Reflected XSS vulnerability in Jenkins Micro Focus Application Automation Tools Plugin

Micro Focus Application Automation Tools Plugin 6.7 and earlier does not escape user input in a form validation response.

This results in a reflected cross-site scripting (XSS) vulnerability.

Micro Focus Application Automation Tools Plugin 6.8 escapes user input in the affected form validation response.

A security hardening since Jenkins 2.275 and LTS 2.263.2 prevents exploitation of this vulnerability.

Permalink: https://github.com/advisories/GHSA-gc2r-ccfh-62v9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1nYzJyLWNjZmgtNjJ2Oc4AAoGF
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: 5 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-gc2r-ccfh-62v9, CVE-2021-22510
References: Repository: https://github.com/jenkinsci/hpe-application-automation-tools-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:hp-application-automation-tools-plugin
Affected Version Ranges: <= 6.7
Fixed in: 6.8