Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1naDR4LXF2M3AtbTlwbc4AA9bq

akbr patch-into was discovered to contain a prototype pollution via the function patchInto

akbr patch-into version 1.0.1 was discovered to contain a prototype pollution via the function patchInto. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.

Permalink: https://github.com/advisories/GHSA-gh4x-qv3p-m9pm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1naDR4LXF2M3AtbTlwbc4AA9bq
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 16 days ago
Updated: 12 days ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-gh4x-qv3p-m9pm, CVE-2024-38991
References: Blast Radius: 0.0

Affected Packages

npm:@akbr/patch-into
Dependent packages: 2
Dependent repositories: 1
Downloads: 15 last month
Affected Version Ranges: = 1.0.1
No known fixed version
All affected versions: 1.0.1