Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1nbTY3LWg1d3ItdzNjds4AA0Ts

Apache Zeppelin Improper Input Validation vulnerability

The improper Input Validation vulnerability in Move folder to Trash feature of Apache Zeppelin allows an attacker to delete the arbitrary files. This issue affects Apache Zeppelin Apache Zeppelin version 0.9.0 and prior versions.

Permalink: https://github.com/advisories/GHSA-gm67-h5wr-w3cv
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1nbTY3LWg1d3ItdzNjds4AA0Ts
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 year ago
Updated: about 1 year ago


CVSS Score: 6.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Identifiers: GHSA-gm67-h5wr-w3cv, CVE-2021-28655
References: Blast Radius: 0.0

Affected Packages

maven:org.apache.zeppelin:zeppelin
Dependent packages: 0
Dependent repositories: 1
Downloads:
Affected Version Ranges: < 0.10.0
Fixed in: 0.10.0
All affected versions: 0.6.0, 0.6.1, 0.6.2, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.2, 0.9.0
All unaffected versions: 0.10.0, 0.10.1, 0.11.0, 0.11.1