Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1ncXFtLTU2NGYtdnZ4cc4AAUxj

Arbitrary code execution in Apache Struts 2

Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted action name that is not properly handled during wildcard matching, a different vulnerability than CVE-2013-2135.

Permalink: https://github.com/advisories/GHSA-gqqm-564f-vvxq
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1ncXFtLTU2NGYtdnZ4cc4AAUxj
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: about 2 months ago


Identifiers: GHSA-gqqm-564f-vvxq, CVE-2013-2134
References:

Affected Packages

maven:org.apache.struts:struts2-core
Versions: < 2.3.14.3
Fixed in: 2.3.14.3