Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1ncjd3LXgyanAtM3hnd84AAvLr

Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication

Caddy before 0.10.13 mishandles TLS client authentication, as demonstrated by an authentication bypass caused by the lack of the StrictHostMatching mode.

Permalink: https://github.com/advisories/GHSA-gr7w-x2jp-3xgw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1ncjd3LXgyanAtM3hnd84AAvLr
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-gr7w-x2jp-3xgw, CVE-2018-21246
References: Repository: https://github.com/caddyserver/caddy
Blast Radius: 32.7

Affected Packages

go:github.com/caddyserver/caddy
Dependent packages: 675
Dependent repositories: 2,153
Downloads:
Affected Version Ranges: < 0.10.13
Fixed in: 0.10.13
All affected versions: 0.5.0, 0.5.1, 0.6.0, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.9.5, 0.10.0, 0.10.1, 0.10.2, 0.10.3, 0.10.4, 0.10.5, 0.10.6, 0.10.7, 0.10.8, 0.10.9, 0.10.10, 0.10.11, 0.10.12
All unaffected versions: 0.10.13, 0.10.14, 0.11.0, 0.11.1, 0.11.2, 0.11.3, 0.11.4, 0.11.5, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5