Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1ndnBnLXZnbXgteGc2d84AA5M9

Denial of Service in Connect2id Nimbus JOSE+JWT

In Connect2id Nimbus JOSE+JWT before 9.37.2, an attacker can cause a denial of service (resource consumption) via a large JWE p2c header value (aka iteration count) for the PasswordBasedDecrypter (PBKDF2) component.

Permalink: https://github.com/advisories/GHSA-gvpg-vgmx-xg6w
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1ndnBnLXZnbXgteGc2d84AA5M9
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 2 months ago
Updated: about 1 month ago


Identifiers: GHSA-gvpg-vgmx-xg6w, CVE-2023-52428
References: Repository: https://bitbucket.org/connect2id/nimbus-jose-jwt
Blast Radius: 0.0

Affected Packages

maven:com.nimbusds:nimbus-jose-jwt
Dependent packages: 806
Dependent repositories: 6,282
Downloads:
Affected Version Ranges: < 9.37.2
Fixed in: 9.37.2
All affected versions: 2.10.1, 2.11.0, 2.12.0, 2.13.0, 2.13.1, 2.14.0, 2.15.0, 2.15.1, 2.15.2, 2.17.1, 2.17.2, 2.18.1, 2.18.2, 2.19.1, 2.22.1, 2.26.1, 3.1.1, 3.1.2, 3.2.1, 3.2.2, 3.8.1, 3.8.2, 3.9.1, 3.9.2, 4.0.1, 4.1.1, 4.3.1, 4.11.1, 4.11.2, 4.13.1, 4.15.1, 4.16.1, 4.16.2, 4.26.1, 4.27.1, 4.31.1, 4.34.1, 4.34.2, 4.36.1, 4.37.1, 4.39.1, 4.39.2, 4.41.1, 4.41.2, 4.41.3, 6.0.1, 6.0.2, 6.1.1, 6.3.1, 6.4.1, 6.4.2, 6.5.1, 7.0.1, 7.2.1, 7.5.1, 7.8.1, 8.2.1, 8.4.1, 8.5.1, 8.14.1, 8.17.1, 8.18.1, 8.20.1, 8.20.2, 8.21.1, 8.22.1, 9.0.1, 9.1.1, 9.1.2, 9.1.3, 9.1.4, 9.1.5, 9.4.1, 9.4.2, 9.6.1, 9.8.1, 9.9.1, 9.9.2, 9.9.3, 9.10.1, 9.11.1, 9.11.2, 9.11.3, 9.12.1, 9.15.1, 9.15.2, 9.16.1, 9.21.1, 9.24.1, 9.24.2, 9.24.3, 9.24.4, 9.25.1, 9.25.2, 9.25.3, 9.25.4, 9.25.5, 9.25.6, 9.30.1, 9.30.2, 9.37.1
All unaffected versions: 9.37.2, 9.37.3