Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1oMjJ4LWhtOGctcnhwZ84AAYT8

Improper Restriction of XML External Entity Reference in Apache OpenNLP

When loading models or dictionaries that contain XML it is possible to perform an XXE attack, since Apache OpenNLP is a library, this only affects applications that load models or dictionaries from untrusted sources. The versions 1.5.0 to 1.5.3, 1.6.0, 1.7.0 to 1.7.2, 1.8.0 to 1.8.1 of Apache OpenNLP are affected.

Permalink: https://github.com/advisories/GHSA-h22x-hm8g-rxpg
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1oMjJ4LWhtOGctcnhwZ84AAYT8
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-h22x-hm8g-rxpg, CVE-2017-12620
References: Blast Radius: 30.6

Affected Packages

maven:org.apache.opennlp:opennlp-tools
Dependent packages: 193
Dependent repositories: 1,341
Downloads:
Affected Version Ranges: >= 1.5.0, <= 1.8.1
Fixed in: 1.8.2
All affected versions: 1.5.3, 1.6.0, 1.7.0, 1.7.1, 1.7.2, 1.8.0, 1.8.1
All unaffected versions: 1.8.2, 1.8.3, 1.8.4, 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 2.0.0, 2.1.0, 2.1.1, 2.2.0, 2.3.0, 2.3.1, 2.3.2