An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1oMnBtLTM3OGMtcGN4eM4AAy5Z

Path traversal vulnerability in gatsby-plugin-sharp


The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server (gatsby develop).

The following steps can be used to reproduce the vulnerability:

# Create a new Gatsby project, and install gatsby-plugin-sharp
$ npm init gatsby
$ cd my-gatsby-site
$ npm install gatsby-plugin-sharp

# Add the plugin to gatsby-config.js
module.exports = {
  plugins: [
      resolve: `gatsby-plugin-sharp`,

# Start the Gatsby develop server
$ gatsby develop

# Execute the path traversal vulnerability
$ curl ""

It should be noted that by default gatsby develop is only accessible via the localhost, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host, -H, or the GATSBY_HOST= environment variable.


A patch has been introduced in [email protected] and [email protected] which mitigates the issue by ensuring that included paths remain within the project directory.


As stated above, by default gatsby develop is only exposed to the localhost For those using the develop server in the default configuration no risk is posed. If other ranges are required, preventing the develop server from being exposed to untrusted interfaces or IP address ranges would mitigate the risk from this vulnerability.

We encourage projects to upgrade to the latest major release branch for all Gatsby plugins to ensure the latest security updates and bug fixes are received in a timely manner.


We would like to thank Patrick Rombouts and Bart Veneman [] for bringing the issue to our attention.

For more information

Email us at [email protected].

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 8 months ago
Updated: about 1 month ago

CVSS Score: 4.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-h2pm-378c-pcxx, CVE-2023-30548

Affected Packages

Versions: < 4.25.1, >= 5.0.0, < 5.8.1
Fixed in: 4.25.1, 5.8.1