An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1oNWNnLTUzZzctZ3Fqd84AA5zS

RPyC's missing security check results in code execution when using numpy.array on the server-side.

An issue in Open Source: RPyC v.4.00 thru v.5.3.1 allows a remote attacker to execute arbitrary code via a crafted script to the __array__ attribute component. This vulnerability was introduced in 9f45f826.

Attack Vector

RPyC services that rely on the __array__ attribute used by numpy are impacted. When the server-side exposes a method that calls the attribute named __array__ for a a client provided netref (e.g., np.array(client_netref)), a remote attacker can craft a class which results in remote code execution


Assuming the system exposes a method that calls the attribute __array__, an attacker can execute code using the vulnerable component.


The fix is available in RPyC 6.0.0. The major version change is because some users may need to set allow_pickle to True when migrating to RPyC 6.


While the recommend fix is to upgrade to RPyC 6.0.0, the workaround is to apply bba1d356 as patch.

Affected Component

The affected component is the __array__ method constructed for NetrefClass.


Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 months ago
Updated: about 1 month ago

CVSS Score: 8.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

Identifiers: GHSA-h5cg-53g7-gqjw, CVE-2024-27758
References: Repository:
Blast Radius: 23.3

Affected Packages

Dependent packages: 49
Dependent repositories: 551
Downloads: 599,170 last month
Affected Version Ranges: >= 4.0.0, < 6.0.0
Fixed in: 6.0.0
All affected versions: 4.0.0, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 5.0.0, 5.0.1, 5.1.0, 5.2.1, 5.2.2, 5.2.3, 5.3.0, 5.3.1
All unaffected versions: 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.3.0, 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 6.0.0