Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1oNnJwLW1wcm0teGdjcc4AA1_v

plone.rest vulnerable to Denial of Service when ++api++ is used many times

Impact

When the ++api++ traverser is accidentally used multiple times in a url, handling it takes increasingly longer, making the server less responsive.

Patches

Patches will be released in plone.rest 2.0.1 and 3.0.1. Series 1.x is not affected.

Workarounds

In your frontend web server (nginx, Apache) you can redirect /++api++/++api++ to /++api++.

Permalink: https://github.com/advisories/GHSA-h6rp-mprm-xgcq
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1oNnJwLW1wcm0teGdjcc4AA1_v
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 2 months ago
Updated: 21 days ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-h6rp-mprm-xgcq, CVE-2023-42457
References:

Affected Packages

pypi:plone.rest
Versions: = 3.0.0, >= 2.0.0a1, < 2.0.1
Fixed in: 3.0.1, 2.0.1