Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1oOHAyLThnNzItcXBnaM4AAxzI

Apache Airflow Google Provider Improper Input Validation vulnerability

Improper Input Validation vulnerability in the Apache Airflow Google Provider. This issue affects Apache Airflow Google Provider versions before 8.10.0.

Permalink: https://github.com/advisories/GHSA-h8p2-8g72-qpgh
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1oOHAyLThnNzItcXBnaM4AAxzI
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 1 year ago
Updated: about 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-h8p2-8g72-qpgh, CVE-2023-25692
References: Repository: https://github.com/apache/airflow
Blast Radius: 19.3

Affected Packages

pypi:apache-airflow-providers-google
Dependent packages: 24
Dependent repositories: 374
Downloads: 4,504,206 last month
Affected Version Ranges: < 8.10.0
Fixed in: 8.10.0
All affected versions: 1.0.0, 2.0.0, 2.1.0, 2.2.0, 3.0.0, 4.0.0, 5.0.0, 5.1.0, 6.0.0, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.5.0, 6.6.0, 6.7.0, 6.8.0, 7.0.0, 8.0.0, 8.1.0, 8.2.0, 8.3.0, 8.4.0, 8.5.0, 8.6.0, 8.7.0, 8.8.0, 8.9.0
All unaffected versions: 8.10.0, 8.11.0, 8.12.0, 9.0.0, 10.0.0, 10.1.0, 10.1.1, 10.2.0, 10.3.0, 10.4.0, 10.5.0, 10.6.0, 10.7.0, 10.8.0, 10.9.0, 10.10.0, 10.10.1, 10.11.0, 10.11.1, 10.12.0, 10.13.0, 10.13.1, 10.14.0, 10.15.0, 10.16.0, 10.17.0