Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1oY2N4LWNnNHYtaHJqeM4AAt-c

JetBrain Ktor before 2.1.0 vulnerable to selection of wrong authentication provider

In JetBrains Ktor before 2.1.0 the wrong authentication provider could be selected in some cases

Permalink: https://github.com/advisories/GHSA-hccx-cg4v-hrjx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1oY2N4LWNnNHYtaHJqeM4AAt-c
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 6.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Identifiers: GHSA-hccx-cg4v-hrjx, CVE-2022-38180
References: Repository: https://github.com/ktorio/ktor
Blast Radius: 9.9

Affected Packages

maven:io.ktor:ktor
Dependent packages: 5
Dependent repositories: 33
Downloads:
Affected Version Ranges: < 2.1.0
Fixed in: 2.1.0
All affected versions: 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.3.0, 1.3.1, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 2.0.0, 2.0.1, 2.0.2, 2.0.3
All unaffected versions: 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.3.10, 2.3.11, 2.3.12