Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1oZ2c3LWNnaHEteGhmNM4AAcjI

Ruby vulnerable to denial of service

When reading text nodes from an XML document, the REXML parser can be coerced in to allocating extremely large string objects which can consume all of the memory on a machine, causing a denial of service.

Jruby resolves this bug in version 1.7.3 as noted in https://www.jruby.org/2013/02/21/jruby-1-7-3.html

Permalink: https://github.com/advisories/GHSA-hgg7-cghq-xhf4
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1oZ2c3LWNnaHEteGhmNM4AAcjI
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 10 months ago


Identifiers: GHSA-hgg7-cghq-xhf4, CVE-2013-1821
References: Blast Radius: 0.0

Affected Packages

maven:org.jruby:jruby
Dependent packages: 151
Dependent repositories: 1,719
Downloads:
Affected Version Ranges: < 1.7.3
Fixed in: 1.7.3
All affected versions: 0.8.3, 0.9.1, 0.9.2, 0.9.8, 0.9.9, 1.0.1, 1.0.2, 1.0.3, 1.1.1, 1.1.2, 1.1.4, 1.1.5, 1.1.6, 1.2.0, 1.3.0, 1.3.1, 1.4.0, 1.4.1, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.5, 1.5.6, 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 1.7.0, 1.7.1, 1.7.2
All unaffected versions: 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 1.7.8, 1.7.9, 1.7.10, 1.7.11, 1.7.12, 1.7.13, 1.7.14, 1.7.15, 1.7.16, 1.7.17, 1.7.18, 1.7.19, 1.7.20, 1.7.21, 1.7.22, 1.7.23, 1.7.24, 1.7.25, 1.7.26, 1.7.27