Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1oZzV4LTN3M3gtN2c5Ns4AAy5v

xwiki-platform-web-templates vulnerable to Eval Injection

Impact

Any user with edit rights on a page (e.g., it's own user page), can execute arbitrary Groovy, Python or Velocity code in XWiki leading to full access to the XWiki installation. The root cause is improper escaping of the information loaded from attachments in imported.vm, importinline.vm, and packagelist.vm. This page is installed by default.

Reproduction steps are described in https://jira.xwiki.org/browse/XWIKI-20267

Patches

The vulnerability has been patched in XWiki 15.0-rc-1, 14.10.1, 14.4.8, and 13.10.11.

Workarounds

The issue can be fixed by applying this patch on imported.vm, importinline.vm, and packagelist.vm.

References

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-hg5x-3w3x-7g96
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1oZzV4LTN3M3gtN2c5Ns4AAy5v
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: about 1 year ago
Updated: 8 months ago


CVSS Score: 9.9
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L

Identifiers: GHSA-hg5x-3w3x-7g96, CVE-2023-29512
References: Repository: https://github.com/xwiki/xwiki-platform
Blast Radius: 1.0

Affected Packages

maven:org.xwiki.platform:xwiki-platform-web-templates
Affected Version Ranges: >= 14.5, < 14.10.1, >= 14.0-rc-1, < 14.4.8, >= 1.0B1, < 13.10.11
Fixed in: 14.10.1, 14.4.8, 13.10.11