Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1qNHI3LXA5ZnAtdzNmM84AA9rZ

Spring Cloud Function Framework vulnerable to Denial of Service

In Spring Cloud Function framework, versions 4.1.x prior to 4.1.2, 4.0.x prior to 4.0.8 an application is vulnerable to a DOS attack when attempting to compose functions with non-existing functions.

Specifically, an application is vulnerable when all of the following are true:

User is using Spring Cloud Function Web module

Affected Spring Products and Versions Spring Cloud Function Framework 4.1.0 to 4.1.2 4.0.0 to 4.0.8

References https://spring.io/security/cve-2022-22979   https://checkmarx.com/blog/spring-function-cloud-dos-cve-2022-22979-and-unintended-function-invocation/  History 2020-01-16: Initial vulnerability report published.

Permalink: https://github.com/advisories/GHSA-j4r7-p9fp-w3f3
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1qNHI3LXA5ZnAtdzNmM84AA9rZ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 5 days ago
Updated: 5 days ago


CVSS Score: 8.2
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Identifiers: GHSA-j4r7-p9fp-w3f3, CVE-2024-22271
References: Repository: https://github.com/spring-cloud/spring-cloud-function
Blast Radius: 18.7

Affected Packages

maven:org.springframework.cloud:spring-cloud-function-context
Dependent packages: 54
Dependent repositories: 189
Downloads:
Affected Version Ranges: >= 4.1.0, < 4.1.2, >= 4.0.0, < 4.0.8
Fixed in: 4.1.2, 4.0.8
All affected versions: 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.6, 4.1.0, 4.1.1
All unaffected versions: 3.1.0, 3.1.1, 3.1.6, 3.1.7, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.2.7, 3.2.8, 3.2.9, 3.2.10, 3.2.11, 3.2.12, 4.1.2, 4.1.3