Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1qNjVmLW12Z3ctcHJwMs4AAXDX

Deserialization of Untrusted Data in Apache OpenJPA

The BrokerFactory functionality in Apache OpenJPA 1.x before 1.2.3 and 2.x before 2.2.2 creates local executable JSP files containing logging trace data produced during deserialization of certain crafted OpenJPA objects, which makes it easier for remote attackers to execute arbitrary code by creating a serialized object and leveraging improperly secured server programs.

Permalink: https://github.com/advisories/GHSA-j65f-mvgw-prp2
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1qNjVmLW12Z3ctcHJwMs4AAXDX
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: about 2 months ago


Identifiers: GHSA-j65f-mvgw-prp2, CVE-2013-1768
References: Repository: https://github.com/apache/openjpa
Blast Radius: 0.0

Affected Packages

maven:org.apache.openjpa:openjpa
Dependent packages: 290
Dependent repositories: 2,333
Downloads:
Affected Version Ranges: >= 2.0.0, < 2.2.2, >= 1.0.0, < 1.2.3
Fixed in: 2.2.2, 1.2.3
All affected versions: 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.1.0, 1.2.0, 1.2.1, 1.2.2, 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1
All unaffected versions: 1.2.3, 2.2.2, 2.3.0, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 3.0.0, 3.1.0, 3.1.1, 3.1.2, 3.2.0, 3.2.1, 3.2.2, 4.0.0