Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1qY21xLTVycnYtajJnNM4AA5Ca

PowerShell is subject to remote code execution vulnerability

Microsoft Security Advisory CVE-2020-0605: .NET Framework Remote Code Execution Vulnerability

Executive Summary

A remote code execution vulnerability exists in .NET software when the software fails to check the source markup of a file.

An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user. If the current user is logged on with administrative user rights, an attacker could take control of the affected system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.

Exploitation of the vulnerability requires that a user open a specially crafted file with an affected version of .NET Framework. In an email attack scenario, an attacker could exploit the vulnerability by sending the specially crafted file to the user and convincing the user to open the file.

The security update addresses the vulnerability by correcting how .NET Framework checks the source markup of a file.

Discussion

Please open a support question to discuss the PowerShell aspects of this advisory.
Please use https://github.com/dotnet/wpf/issues/2424 for discussion of the .NET WPF aspects of this advisory.

Affected Software

The vulnerability affects PowerShell prior to the following versions:

PowerShell Core Version Fixed in
6.2 Not Affected
7.0 7.0.0

Advisory FAQ

How do I know if I am affected?

If all of the following are true:

  1. Run pwsh -v, then, check the version in the table in Affected Software to see if your version of PowerShell is affected.
  2. If you are running a version of PowerShell where the executable is not pwsh or pwsh.exe, then you are affected. This only existed for preview version of 7.0.

How do I update to an unaffected version?

Follow the instructions at Installing PowerShell to install the latest version of PowerShell.

Other Information

Reporting Security Issues

If you have found a potential security issue in PowerShell,
please email details to [email protected].

Support

You can ask questions about this issue on GitHub in the PowerShell organization.
This is located at https://github.com/PowerShell/.
The Announcements repo (https://github.com/PowerShell/Announcements)
will contain this bulletin as an issue and will include a link to a discussion issue where you can ask questions.

What if the update breaks my script or module?

You can uninstall the newer version of PowerShell and install the previous version of PowerShell.
This should be treated as a temporary measure.
Therefore, the script or module should be updated to work with the patched version of PowerShell.

Acknowledgments

Soroush Dalili (@irsdl)

External Links

CVE-2020-0605

Revisions

V1.0 (March 10, 2020): Advisory published.

Version 1.0
Last Updated 2020-03-10

Permalink: https://github.com/advisories/GHSA-jcmq-5rrv-j2g4
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1qY21xLTVycnYtajJnNM4AA5Ca
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 28 days ago
Updated: 28 days ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-jcmq-5rrv-j2g4
References:

Affected Packages

nuget:PowerShell
Versions: < 7.0.0
Fixed in: 7.0.0