Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1qY3h2LTJqM2gtbWc1Oc0WTg

Improper Restriction of Operations within the Bounds of a Memory Buffer in OpenCV

OpenCV 3.3.1 (corresponding with opencv-python and opencv-contrib-python 3.3.1.11) has a Buffer Overflow in the cv::PxMDecoder::readData function in grfmt_pxm.cpp, because an incorrect size value is used.

Permalink: https://github.com/advisories/GHSA-jcxv-2j3h-mg59
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1qY3h2LTJqM2gtbWc1Oc0WTg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 2 years ago
Updated: about 1 year ago


CVSS Score: 6.5
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Identifiers: GHSA-jcxv-2j3h-mg59, CVE-2017-17760
References: Repository: https://github.com/opencv/opencv
Blast Radius: 31.4

Affected Packages

pypi:opencv-contrib-python
Dependent packages: 250
Dependent repositories: 8,355
Downloads: 2,257,943 last month
Affected Version Ranges: <= 3.3.1.11
Fixed in: 3.4.0.12
All affected versions:
All unaffected versions:
pypi:opencv-python
Dependent packages: 2,667
Dependent repositories: 67,670
Downloads: 13,393,756 last month
Affected Version Ranges: <= 3.3.1.11
Fixed in: 3.4.0.12
All affected versions:
All unaffected versions: 3.1.0