Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1qZjlqLWh4MmotbTl4aM4AAlx7

CSRF vulnerability in Jenkins Database Plugin

Database Plugin 1.6 and earlier does not require POST requests for the database console, resulting in a cross-site request forgery (CSRF) vulnerability.

This vulnerability allows attackers to execute arbitrary SQL scripts.

Database Plugin 1.7 removes the database console.

Permalink: https://github.com/advisories/GHSA-jf9j-hx2j-m9xh
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1qZjlqLWh4MmotbTl4aM4AAlx7
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: 5 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-jf9j-hx2j-m9xh, CVE-2020-2240
References: Repository: https://github.com/jenkinsci/database-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:database
Affected Version Ranges: <= 1.6
Fixed in: 1.7