Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1qbWc0LXg0dnAtNmM2eM37rw

Apache Geode vulnerable to Incorrect Authorization

When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.

Permalink: https://github.com/advisories/GHSA-jmg4-x4vp-6c6x
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1qbWc0LXg0dnAtNmM2eM37rw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: 3 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-jmg4-x4vp-6c6x, CVE-2017-15695
References: Repository: https://github.com/apache/geode
Blast Radius: 22.6

Affected Packages

maven:org.apache.geode:geode-core
Dependent packages: 51
Dependent repositories: 368
Downloads:
Affected Version Ranges: >= 1.0.0, < 1.5.0
Fixed in: 1.5.0
All affected versions: 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.3.0, 1.4.0
All unaffected versions: 1.5.0, 1.6.0, 1.7.0, 1.8.0, 1.9.0, 1.9.1, 1.9.2, 1.10.0, 1.11.0, 1.12.0, 1.12.1, 1.12.2, 1.12.3, 1.12.4, 1.12.5, 1.12.6, 1.12.7, 1.12.8, 1.12.9, 1.13.0, 1.13.1, 1.13.2, 1.13.3, 1.13.4, 1.13.5, 1.13.6, 1.13.7, 1.13.8, 1.14.0, 1.14.1, 1.14.2, 1.14.3, 1.14.4, 1.15.0, 1.15.1